c++11 support

nenadus's picture

Hello, everyone!

I succeeded to build the OpenCascade v7.3.0 using various compilers (VS2010-VS2017, GCC4.8, GCC4.4) in various modes and everything finished great. However, when I tried to build my application (which previously used v6.9) with the v7.3.0 one, everything worked great on newer MS compilers, but, I hit errors with GCCs, which say I need to build with c++11 support enabled.

Does the latest OpenCascade sources require partial c++11 support or I'm using wrong the framework?

Best regards,
Nenad.

drazmyslovich's picture

Hi, Nenad,you can find the

Hi, Nenad,

you can find the necessary information in the documentation (https://dev.opencascade.org/doc/overview/html/occt_dev_guides__upgrade.html)

Upgrade to OCCT 7.0.0
Porting of user applications from an earlier OCCT version to version 7.0.0 requires taking into account the following major changes.

Building OCCT now requires compiler supporting some C++11 features. The supported compilers are:

MSVC: version 10 (Visual Studio 2010) or later
GCC: version 4.3 or later
CLang: version 3.6 or later
ICC: version XE 2013 SP 1 or later
When compiling code that uses OCCT with GCC and CLang compilers, it is necessary to use compiler option -std=c++0x (or its siblings) to enable C++11 features.

Regards,
Dima

nenadus's picture

Dima, Thank you very much for

Dima,

Thank you very much for your reply! Btw, I get error:

Error page
This document/page is not found.

when I try to open above URL. I tried both Chrome and MS Edge :-(.

Thanks,
Nenad.

drazmyslovich's picture

Try copy and paste the URL.

Try copy and paste the URL.

www.opencascade.com

Copyright 2011-2017
OPEN CASCADE SAS
Contact us