Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: paint

I am using eclipse3.x.
All I do, I put all the samples java classes (SamplesStarter) in a package name 'cascade' instead of (default package) then try to run the samples but I get a message Like following:
"
Info: Create Viewer
Info: Done creation of Viewer2d
Info: Load NativePaint lib...
Info: Loading NativePaint lib done
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: paint
at cascade.CASCADEView3d.paint(Native Method)
at sun.awt.RepaintArea.paintComponent(Unknown Source)
at sun.awt.RepaintArea.paint(Unknown Source)
at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
"
The paint is commented. I uncommented it but still getting the same exception.
Eventually jvm crashes.
Every thing is fine with (default package).
What it skips or is wrong with package name 'cascade'??
Thanks.

Selim's picture

This is what I get when JVM crashes.
Probably application skips a dll or some other thing which is available when the classes are in default package. When they are put in a named package, It skips what It does not when the package is default.

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x03134948, pid=3784, tid=3612
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0-rc-b63 mixed mode, sharing)
# Problematic frame:
# C [TKV3d.dll+0x64948]
#
# An error report file with more information is saved as hs_err_pid3784.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

Kreshnik's picture

Hi Selim

I've the same problem. Sample works in default package but when I put it in the package "opencascade" I've a java.lang.UnsatisfiedLinkError.

http://www.opencascade.org/org/forum/thread_9295/

Did you find the solution ?

Thank you for your answer

Chenthil's picture

Hello HANSANI,
if you know the solution for java.lang.UnsatisfiedLinkError,pls forward it to me
thank you

Jan Brüninghaus's picture